JDMCITY.COM
Advertise with us!

Go Back   JDMCITY.COM > Manufacturer Forum > Mitsubishi Forum

Reply
 
Old 11/12/2012, 05:56 PM   #1
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Need Help!!!!

I own a 05 eclipse gts..my car started fine this morning and drove fine to work without showing any signs of anything wrong with it.. i go to my first break and it will not start? My dash lights still light up and radio works..i thought it was my starter since it wont turn over..i turn the key the lights come one and i go to crank it and it clicks once then nothing? I replaced the starter and nothing? Took it in to get my old one tested and it came out still good and working..took my battery out and got it tested and thats still good..now im stumped and dont have a clue what else it could be? Relay switches? Ignition coil? Can anyone help shed some light on this?

  Reply With Quote
Old 11/12/2012, 06:00 PM   #2
ThatGuyVanny
JDM Fan
 
ThatGuyVanny's Avatar
 
ThatGuyVanny is offline
Join Date: Oct 2012
Location: Des Moines
Posts: 47

 
Default Re: Need Help!!!!

Have you gotten the Ignition coil checked? this happened to me and i found them my coil was corroded...

  Reply With Quote
Old 11/12/2012, 06:02 PM   #3
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Re: Need Help!!!!

No i havent that was gonna be my next step cuz i dont know what else it could really be? Where exactly is the ignition coil located and how hard is it to change?

  Reply With Quote
Old 11/12/2012, 06:07 PM   #4
ThatGuyVanny
JDM Fan
 
ThatGuyVanny's Avatar
 
ThatGuyVanny is offline
Join Date: Oct 2012
Location: Des Moines
Posts: 47

 
Default Re: Need Help!!!!

i really didn't know i had to let the shop fix it because i didnt have the tools.....SMH but check you manuals they might have some about starters and stuff. it took mine about an hour because that motherfucker was slow. Oh and also check out youtube haha

  Reply With Quote
Old 11/12/2012, 06:11 PM   #5
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Re: Need Help!!!!

Okay i will google it..but yea i replaced the starter already for nothing cuz my old one is still good too so now im just sitting her with two starters and and non running car..but thanks

  Reply With Quote
Old 11/12/2012, 06:13 PM   #6
ThatGuyVanny
JDM Fan
 
ThatGuyVanny's Avatar
 
ThatGuyVanny is offline
Join Date: Oct 2012
Location: Des Moines
Posts: 47

 
Default Re: Need Help!!!!

Alright no problem man i wish you good luck

  Reply With Quote
Old 11/12/2012, 08:46 PM   #7
99eclipse
JDM King
 
99eclipse's Avatar
 
99eclipse is offline
Join Date: Aug 2011
Location: Moravia Iowa
Posts: 1,129

 
Default Re: Need Help!!!!

idk if its any help but i had the same problem as you on my 2g gst, and it was a blown fuse, has happened three times now,

  Reply With Quote
Old 11/12/2012, 09:32 PM   #8
luis31
Jefe De Jefes
 
luis31's Avatar
 
luis31 is offline
Join Date: Oct 2007
Posts: 950

 
Default Re: Need Help!!!!

Alternator


__________________

DSM'S, WALKING THE THIN LINE BETWEEN STARTING AND JUNKYARD SINCE '89
  Reply With Quote
Old 11/12/2012, 09:48 PM   #9
The Laser
JDM King
 
The Laser's Avatar
 
The Laser is offline
Join Date: Jul 2009
Location: Boone, IA
Posts: 1,327

 
Default Re: Need Help!!!!

The exact same thing happened to me one night. Found out my ground wire was a little fucked up and slightly corroded. Took it to work, cleaned it up, and its been running great ever since. If you haven't tried that yet, give it a shot.


__________________

"does this have V-tec? i bet it has V-tec"
"V-tec is for fags. This has boost"
  Reply With Quote
Old 11/12/2012, 09:49 PM   #10
The Laser
JDM King
 
The Laser's Avatar
 
The Laser is offline
Join Date: Jul 2009
Location: Boone, IA
Posts: 1,327

 
Default Re: Need Help!!!!

Quote:
Originally Posted by 99eclipse View Post
idk if its any help but i had the same problem as you on my 2g gst, and it was a blown fuse, has happened three times now,
A 97 gst is a lot different than an 05 gts. My stratus is exactly the same aside from being a 4 banger.


__________________

"does this have V-tec? i bet it has V-tec"
"V-tec is for fags. This has boost"
  Reply With Quote
Old 11/12/2012, 09:53 PM   #11
99eclipse
JDM King
 
99eclipse's Avatar
 
99eclipse is offline
Join Date: Aug 2011
Location: Moravia Iowa
Posts: 1,129

 
Default Re: Need Help!!!!

Quote:
Originally Posted by The Laser View Post
A 97 gst is a lot different than an 05 gts. My stratus is exactly the same aside from being a 4 banger.
i know it is, but i fuse could be a possibity with his car as well, was just an idea from my own experience

  Reply With Quote
Old 11/12/2012, 10:03 PM   #12
The Laser
JDM King
 
The Laser's Avatar
 
The Laser is offline
Join Date: Jul 2009
Location: Boone, IA
Posts: 1,327

 
Default Re: Need Help!!!!

Quote:
Originally Posted by 99eclipse View Post
i know it is, but i fuse could be a possibity with his car as well, was just an idea from my own experience
Fair enough lol.


__________________

"does this have V-tec? i bet it has V-tec"
"V-tec is for fags. This has boost"
  Reply With Quote
Old 11/13/2012, 05:36 PM   #13
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Re: Need Help!!!!

Thanks for the help guys..went through all my fuses and they were good..checked my wires and figured it could b my power wire from my battery to the starter so went and bought a new wire and just tested it..the car started right up..so as i was disconnecting the old wires to put the new one in i realized the heads on the wires were kinda corroded so i cleaned them up and gave it a shot b4 i actually changed the wire and it was good..so i guess the corroded heads just werent getting enough power to kick start the starter..which sucks bcuz i couldnt c the heads bcuz they are underneath the power post thing..well i guess i got a new starter in there now..lol..thanks guys

  Reply With Quote
Old 11/13/2012, 06:14 PM   #14
99eclipse
JDM King
 
99eclipse's Avatar
 
99eclipse is offline
Join Date: Aug 2011
Location: Moravia Iowa
Posts: 1,129

 
Default Re: Need Help!!!!

Quote:
Originally Posted by asianboy3t View Post
Thanks for the help guys..went through all my fuses and they were good..checked my wires and figured it could b my power wire from my battery to the starter so went and bought a new wire and just tested it..the car started right up..so as i was disconnecting the old wires to put the new one in i realized the heads on the wires were kinda corroded so i cleaned them up and gave it a shot b4 i actually changed the wire and it was good..so i guess the corroded heads just werent getting enough power to kick start the starter..which sucks bcuz i couldnt c the heads bcuz they are underneath the power post thing..well i guess i got a new starter in there now..lol..thanks guys
ha at least it was an easy fix!

  Reply With Quote
Old 11/13/2012, 06:18 PM   #15
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Re: Need Help!!!!

Yea if i wouldve checked that from the start..lol instead i spent a few hrs out in the freezing cold changing the starter out for nothing

  Reply With Quote
Old 11/13/2012, 09:22 PM   #16
mattcossel29
jackstand ballin
 
mattcossel29's Avatar
 
mattcossel29 is offline
Join Date: Mar 2009
Location: Newton, IA
Posts: 1,064

 
Default Re: Need Help!!!!

Word of advice for any amature mechanic.Always check the free/cheap stuff first. Than if it is not fixed move to the harder and more expensive options.


__________________

Romans 6:23 - "For the wages of sin is death, but the gift of God is eternal life through Christ Jesus our Lord."

  Reply With Quote
Old 11/13/2012, 09:37 PM   #17
99eclipse
JDM King
 
99eclipse's Avatar
 
99eclipse is offline
Join Date: Aug 2011
Location: Moravia Iowa
Posts: 1,129

 
Default Re: Need Help!!!!

Quote:
Originally Posted by mattcossel29 View Post
Word of advice for any amature mechanic.Always check the free/cheap stuff first. Than if it is not fixed move to the harder and more expensive options.
thats exactly what i do when i have a problem,

  Reply With Quote
Old 11/14/2012, 08:24 PM   #18
asianboy3t
JDM Soldier
 
asianboy3t's Avatar
 
asianboy3t is offline
Join Date: Feb 2011
Location: Ames, Iowa
Posts: 126

 
Default Re: Need Help!!!!

i sure will next time..beats putting all that labor in for nothing

  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:59 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.