JDMCITY.COM
Advertise with us!

Go Back   JDMCITY.COM > Manufacturer Forum > Honda/Acura Forum > Acura RSX/EP3/K-series

Reply
 
Old 11/22/2010, 08:59 PM   #1
f22b1_94
JDM Knight
 
f22b1_94's Avatar
 
f22b1_94 is offline
Join Date: Nov 2009
Location: Knoxville
Posts: 580

 
Default HELP ME!

Where the hell is the IACV on a K20A3 engine? My car is throwing a P0505, and people are saying to clean this thing...Can anyone help me out?


__________________

  Reply With Quote
Old 11/23/2010, 12:15 AM   #2
4DRLX
JDM Knight
 
4DRLX's Avatar
 
4DRLX is offline
Join Date: Apr 2010
Location: Indianola
Posts: 717

 
Default Re: HELP ME!

it looks like this, and from what ive read its on the throttle body.


__________________

  Reply With Quote
Old 11/24/2010, 08:40 PM   #3
f22b1_94
JDM Knight
 
f22b1_94's Avatar
 
f22b1_94 is offline
Join Date: Nov 2009
Location: Knoxville
Posts: 580

 
Default Re: HELP ME!

found it and cleaned it!


__________________

  Reply With Quote
Old 11/24/2010, 08:56 PM   #4
4DRLX
JDM Knight
 
4DRLX's Avatar
 
4DRLX is offline
Join Date: Apr 2010
Location: Indianola
Posts: 717

 
Default Re: HELP ME!

was i correct? i just posted that from what i looked up.

also did it fix your problem?


__________________

  Reply With Quote
Old 11/25/2010, 09:17 AM   #5
f22b1_94
JDM Knight
 
f22b1_94's Avatar
 
f22b1_94 is offline
Join Date: Nov 2009
Location: Knoxville
Posts: 580

 
Default Re: HELP ME!

No, it didnt fix it...I believe it just needs a new one?(IACV) Cleaned the whole TB and sensors.... Put it back together and it still was surging. It wasnt as bad as before...But it still does it! O well, i just sold it anyways.


__________________

  Reply With Quote
Old 11/25/2010, 10:28 AM   #6
benstuh
JDM Soldier
 
benstuh's Avatar
 
benstuh is offline
Join Date: Jun 2009
Location: Des Moines
Posts: 433

 
Default Re: HELP ME!

Quote:
Originally Posted by f22b1_94 View Post
No, it didnt fix it...I believe it just needs a new one?(IACV) Cleaned the whole TB and sensors.... Put it back together and it still was surging. It wasnt as bad as before...But it still does it! O well, i just sold it anyways.
lol.

so any plans on getting a different car?

  Reply With Quote
Old 08/24/2011, 07:10 PM   #7
f22b1_94
JDM Knight
 
f22b1_94's Avatar
 
f22b1_94 is offline
Join Date: Nov 2009
Location: Knoxville
Posts: 580

 
Default Re: HELP ME!

Yea i got a 07 civic si sedan!!


__________________

  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:12 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.