JDMCITY.COM
Advertise with us!

Go Back   JDMCITY.COM > Manufacturer Forum > Subaru Forum

Reply
 
Old 09/25/2011, 10:17 PM   #1
lulzcow
JDM Soldier
 
lulzcow's Avatar
 
lulzcow is offline
Join Date: Jul 2011
Location: Ames
Posts: 108

 
Wrench Bad Timing on my Legacy

From the noises my engine is making, I can only assume the timing is off.

When I bought the car, it was a piece. It is a 1997 Legacy L wagon with the 2.5GT motor swapped in, which came with an MSD coilpack and wires, a DIY intake, and WRX exhaust. Since purchasing it (with the help of a friend), I have replaced intake manifold and throttle body gaskets, fixed all vacuum and fuel leaks, put the 2.5 ECU in, added upgraded WRX headers, a Weapon-R intake designed for the motor, and a few suspension mods.

For a while, everything seemed right on the car. Then this ticking noise popped up. It is in sync with the RPMs of the motor. I am just curious, is there anyone around Des Moines that could check this out for me (as I am still learning, and don't want to fudge this up), besides the Subaru dealership?

Also, does the assessment of it having bad timing seem correct, or might I be looking at a more sinister internal issue?

  Reply With Quote
Old 09/26/2011, 10:20 AM   #2
importsusa
Vinyl Specialist
 
importsusa's Avatar
 
importsusa is offline
Join Date: Sep 2009
Location: South DSM,IA
Posts: 2,868

 
Default Re: Bad Timing on my Legacy

Quote:
Originally Posted by lulzcow View Post
From the noises my engine is making, I can only assume the timing is off.

When I bought the car, it was a piece. It is a 1997 Legacy L wagon with the 2.5GT motor swapped in, which came with an MSD coilpack and wires, a DIY intake, and WRX exhaust. Since purchasing it (with the help of a friend), I have replaced intake manifold and throttle body gaskets, fixed all vacuum and fuel leaks, put the 2.5 ECU in, added upgraded WRX headers, a Weapon-R intake designed for the motor, and a few suspension mods.

For a while, everything seemed right on the car. Then this ticking noise popped up. It is in sync with the RPMs of the motor. I am just curious, is there anyone around Des Moines that could check this out for me (as I am still learning, and don't want to fudge this up), besides the Subaru dealership?

Also, does the assessment of it having bad timing seem correct, or might I be looking at a more sinister internal issue?
is the ticking sound closer to the valve covers or does it sound like it is coming from below....around crank? The noise (could) possibly be rockers/lifters loose since you say it is with rpm as you rev up etc. Not sure if that could be correct diagnose but it is a start.

May need to search on other forums for similar noise/issue.............could help at least pin point a rough area.


__________________

come check us out..............
  Reply With Quote
Old 09/27/2011, 07:54 PM   #3
lulzcow
JDM Soldier
 
lulzcow's Avatar
 
lulzcow is offline
Join Date: Jul 2011
Location: Ames
Posts: 108

 
Default Re: Bad Timing on my Legacy

Hey I appreciate your input! The guy who built my motor is in the Subaru club, said it sounded like the hydraulic lifters. When I can get him to, we are going to replace the lifters. And that is a very similar diagnosis to what the Subaru forum guys offered. Thank you for the input, this gives me hope that my engine won't blow up...anytime soon.
The noise definitely seemed to come from towards the bottom/mid of the motor. Took a while to pinpoint.


__________________

Haters gon' hate
  Reply With Quote
Old 09/29/2011, 10:29 PM   #4
mattcossel29
jackstand ballin
 
mattcossel29's Avatar
 
mattcossel29 is offline
Join Date: Mar 2009
Location: Newton, IA
Posts: 1,064

 
Default Re: Bad Timing on my Legacy

These are nice for this sort of thing!
http://www.amazon.com/Mechanics-Stet.../dp/B000RB5WQY

If it is coming from the middle or bottom of the engine it could be piston slap or rod knock.


__________________

Romans 6:23 - "For the wages of sin is death, but the gift of God is eternal life through Christ Jesus our Lord."

  Reply With Quote
Old 10/10/2011, 10:51 AM   #5
lulzcow
JDM Soldier
 
lulzcow's Avatar
 
lulzcow is offline
Join Date: Jul 2011
Location: Ames
Posts: 108

 
Default Re: Bad Timing on my Legacy

relatively good news. i had recently had my oil changed, and was lazy and went to a place to do it. they only put like 1 qt in. filled her up with royal purple and problem solved.


__________________

Haters gon' hate
  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:32 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.